wxPython for RSW client

A place for general chatter about games in progress, games completed, strategy advice, bug reports, or really anything at all that relates in some vague way to RSW.
Post Reply
jdhedden
Posts: 4
Joined: Thu Jan 16, 2020 8:04 pm

wxPython for RSW client

Post by jdhedden »

I recently upgraded my Linux system, and had trouble with the RSV client because with the update to the versions of Python, I needed to reinstall wxPython. I figured out that you have to use an older version of wxPython, namely, 4.0.7.post2. I recommend that the client download page be updated to specify installation of wxPython using the following command:

Code: Select all

sudo pip2 install wxPython==4.0.7.post2
or to download from here https://pypi.org/project/wxPython/4.0.7.post2/#files and install as required.
drwr
Posts: 639
Joined: Sat Dec 10, 2005 10:56 am
Location: Glendale, CA
Contact:

Re: wxPython for RSW client

Post by drwr »

I'll make the update, thanks! It also requires Python 2, and I'm not sure that's spelled out either.
Post Reply